Base Mainnet | Intermittent transaction confirmation latency

Incident Report for Base

Resolved

This incident has been resolved.
Posted May 17, 2025 - 19:45 UTC

Update

The network has been functioning well over the past few days, we've implemented fixes and improvements to transaction processing pipelines, and we're closely monitoring the situation to ensure smooth performance going forward
Posted May 17, 2025 - 15:39 UTC

Update

Follow-up for Node Operators

If your node has fallen behind, please review our performance tuning recommendations:
https://docs.base.org/chain/node-performance

Still seeing issues after applying those changes? Reach out in the #node-operators channel of the Base Discord (https://base.org/discord)—we’re happy to help.
Posted May 14, 2025 - 17:00 UTC

Monitoring

We're currently observing some localized delays in transaction confirmation due to increased activity and dynamic fee conditions. The network is processing transactions normally, but some may take longer than expected to be included.

We're closely monitoring the situation to ensure smooth performance across the board.

If you're seeing delays, please make sure you're using competitive fees and have retry logic in place for time-sensitive operations.
Posted May 13, 2025 - 15:23 UTC
This incident affected: Mainnet (Public RPC API, Transaction pool).